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1 Clinical Assessment Layout Manager (CALM) Tool

This application facilitates the preparation of online clinical assessment entry forms. Each online
clinical assessment consists of multiple pages. Each page consists of an arbitary depth container
and display elements hierarchy. A container contains zero or more display components. A display
component corresponds to a form field such as a text entry field, radio button or to styled text.
Each container has a layout manager which constraints how its children (other containers and/or
display elements) are laid out with each other and their parent container.

1.1 Installation

To install and run CALM, you need Java Development Kit version 1.6 or later and Apache Ant build
tool version 1.6 or later. CALM is tested under Unix like operating systems and under Windows
using Cygwin. It is reported that it also runs under Mac OS. First, you need to untar your CALM
distribution to a directory of your liking using the command

tar xzvf calm_vX_Y.tgz

Assuming you have unpacked CALM to your home directory, a sample build, configuration and
setup session is shown below;

$ cd $HOME/BIRN/cas_layout
$ ant
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[echo] =========================================================
[echo] *
[echo] * Preparing conf/caslayout.properties file interactively
[echo] *
[echo] =========================================================
[echo]
[echo]
[echo] In order to connect to your database CALM needs to know the JDBC
[echo] database connection URL. For Oracle it looks like
[echo] jdbc:oracle:thin:@<your-gpop-hostname>:<connection-port>:<SID>
[echo] For default rack Oracle installations SID is ’orcl1’ and port is 1521
[echo] A valid JDBC url for UCSD fmri gpop looks like
[echo]
[echo] jdbc:oracle:thin:@fmri-gpop.nbirn.net:1521:orcl1
[echo]
[echo] For postgres
[echo] jdbc:postgresql://<db-server-hostname>/<db-name>
[echo]
[echo] A valid postgres JDBC url is
[echo] jdbc:postgresql://localhost/fbirn
[echo]
[echo]
[input] Please enter your JDBC url string for database connection:
jdbc:oracle:thin:@fmri-gpop.nbirn.net:1521:orcl1
[input] Please enter database username CALM will use to connect to your DB:
<a-db-user-name>
[input] Please enter your database type (oracle/postgres):
oracle

After this, CALM is built and configured for your HID database. You can run CALM after
setting an environment variable CALM HOME;

$ export CALM_HOME=$HOME/BIRN/cas_layout
$ cd $HOME/BIRN/cas_layout/bin
$ calm.sh

To regenerate $HOME/BIRN/cas layout/bin/calm.sh and $HOME/BIRN/cas layout/caslayout.properties,
just delete them and run ant again.
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2 Using CALM

In this section each of the menu options of CALM is described.

2.1 File Menu

2.1.1 New

This menu option is used to create a new assessment form document. You will first be presented
with the available assessments in the connected database. CALM connects to your database during
startup and remains connected until you quit. At this point you will see a dialog box like below.

If you want to work on a brand new assessment that is not available in the database, press the
Cancel button. You will see the following dialog

Enter the name of the new assessment and press OK.

2.1.2 Load

This menu option is used to load an existing assessment form document. An assessment form
document is a XML document that contains form layout, assessment and assessment - form field
association information. There are some example assessment form documents in the examples
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directory under $CAS LAYOUT HOME/examples.

2.1.3 Save

This menu option is used to save the currently edited assessment form document.

2.1.4 Save As

This menu option is used to save the currently edited assessment form document with a different
name .

2.1.5 Quit

This menu option is used to to exit the application. You have to save your changes before quitting
the application, otherwise they will be lost.
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2.2 Tools Menu

2.2.1 Add Container (Alt-C)

This menu item is used to add a container to the current page of the clinical assessment you are
working on. A container contains zero or more display components. A display component corre-
sponds to a form field like text entry field, radio button or to styled text. You can also press the

toolbar button or the shortcut key Alt-C to achieve the same thing.
You will see a dialog box like the one below;
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In this dialog box, you can edit the layout for the container you want to add to the clinical
assessment by changing the number of rows and/or the columns of the grid, while specifying the
size of an individual grid cell in percentages.
You select an individual cell by pointing and clicking on that cell in the preview. In the dialog box
above, for example, the second row, first column is currently selected. The column occupies half
of the container width (50%) and 40% of the container height. In the selected row , it seems that
there are only two columns. Actually there are four columns like the other rows, but two of the
columns have 0% width. You can specify 0% height for a row as well.
When you edit any of the percentages, please do not forget to press Enter , to apply the change.
Once you change the percentage of a grid cell’s row or column, the remaining height/width in the
container will be distributed preserving the ratio of height/width of the other rows, cells. Therefore,
you may need to adjust the percentages more than once until you get the desired layout.
You can also set all of the column width values for a row or a range of rows at the same time, by
selecting lower and upper bounds (inclusive) of rows in the Set Column percents for row(s) section
of the dialog box and pressing Update Row button. You will see a dialog box similar to the one
below, where you can enter individual percentages.

Once you are satisfied with the cell arrangements, press the OK button and Left click in any empty
cell on the form layout pane of the CALM.
You can edit an existing container, either by left double-clicking in an empty cell or Ctrl - left double
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click anywhere with the particular container you are interested. The Container grid lines are only
for visual guidance. They are not included in the final online assessment forms.

2.2.2 Adding a new row after a selected row in a container

You can append rows and columns to the end of the container by using the dropdowns in the
’Adjust row/column numbers’ section of the Edit Layout dialog. To add a new row after any row,

1. select the row you want to add a new row after.

2. Press the right mouse button to bring up the popup menu and select ’Add a row after the
selected row’. A new row with equal column percents will be added after the selected row in
the preview panel (Actually the preview panel is the skeleton view of the actual container you
are editing, therefore any change here will automatically affect the actual container. Cancel
button will not undo the changes. This will be fixed in later versions)

3. Press the OK button.

2.2.3 Deleting the selected row from the Container

1. Select the row you want to delete in the preview panel in the Edit Layout Dialog by clicking
anywhere inside the row.

2. Press the right mouse button to bring up the popup menu and select ’Delete the selected row’.

3. Press OK button
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2.2.4 Add Text (Alt-E)

This menu item is used to add multiline styled text to one of the cells in a container. After selecting
the menu item or the corresponding toolbar button, left click in the grid cell you want to add text.
You will first see a property editor where you can enter the styled text.

• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_question { color: blue; font-family: arial }

Then you can enter sars question as the class for a multiline text component to be added to
the CALM form layout design screen. In the final generated JSP the text will endup in blue
Arial font.

• justification (default Left justified) - used to specify the justification (alignment) of the com-
ponent within its container cell.

• label - used to specify multiline line text. You can also embed basic HTML adornments
(<b>,<i>,<u> ).

A limited number of HTML tags are recognized as shown below.

2.2.5 Add Radio Button (Alt-R)

This menu item is used to add a radio button with optional text to one of the cells in a container.
After selecting the menu item, the corresponding toolbar button or shortcut Alt-R, left click in the
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grid cell you want to add a radio button.

• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_radio { color: blue; font-family: arial;
border-style: solid;
border-color: #0000ff

}

Then you can enter sars radio as the class for the radio button added to the CALM form
layout design screen. In the final generated JSP the text of the radio button will will end up
in blue Arial font and there will be a blue border around the radio button and its text.

• justification (default Center justified) - used to specify the justification (alignment) of the
component within its container cell.

• text - the text that will appear to the right of the radio button

• value (optional) - the value that will be submitted to the web server when this radio button
is pressed. In most cases this value is set using the associated score’s score code information,
thus in most cases you can leave this field blank.

2.2.6 Add Check Box (Alt-X)

This menu item is used to add a check box with optional text to one of the cells in a container.
After selecting the menu item, the corresponding toolbar button or shortcut Alt-X, left click in the
grid cell you want to add a check box.

11



• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_check { color: blue; font-family: arial;
border-style: solid;
border-color: #0000ff

}

Then you can enter sars check as the class for the check box added to the CALM form layout
design screen. In the final generated JSP the text of the check box will will end up in blue
Arial font and there will be a blue border around the check box and its text.

• justification (default Center justified) - used to specify the justification (alignment) of the
component within its container cell.

• text - the text that will appear to the right of the check box

• value (optional) - the value that will be submitted to the web server when this check box is
selected. In most cases this value is set using the associated score’s score code information,
thus it should be okay to leave this field blank.

2.2.7 Add Text Input Field (Alt-T )

This menu item is used to add a text input field to one of the cells in a container. After selecting
the menu item, the corresponding toolbar button or shortcut Alt-T, left click in the grid cell you
want to add text input field.
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• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_textfield { color: blue; font-family: arial;
border-style: solid;
border-color: #0000ff

}

Then you can enter sars textfield as the class for the text field added to the CALM form
layout design screen. In the final generated JSP the text in the text field will will end up in
blue Arial font and there will be a blue border around the text field.

• fieldLength (default 10 characters)

• justification (default Left justified) - used to specify the justification (alignment) of the com-
ponent within its container cell.

• maxFieldLength (default 10) - maximum number of characters that can be entered into this
text input field.

2.2.8 Add Text Area Field (Alt-A )

This menu item is used to add a text area input field to one of the cells in a container. After
selecting the menu item, the corresponding toolbar button or shortcut Alt-A, left click in the grid
cell you want to add text area field.

• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_textarea { color: blue; font-family: arial;
border-style: solid;
border-color: #0000ff

}
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Then you can enter sars textarea as the class for the text field added to the CALM form
layout design screen. In the final generated JSP the text in the text area will will end up in
blue Arial font and there will be a blue border around the text field.

• justification (default Left justified) - used to specify the justification (alignment) of the com-
ponent within its container cell.

• numCols - width of the textarea in characters

• numRows - the height of the textarea in number of lines

2.2.9 Add Dropdown Field (Alt-D )

This menu item is used to add a static dropdown field to one of the cells in a container. Af-
ter selecting the menu item, the corresponding toolbar button or shortcut Alt-D, you will see a
dropdown selection dialog where you can create your own dropdown with its option list or selected
from canned dropdowns. Currently, the only canned dropdown is the informant relation dropdown.
After that you will see a dialog box like the one below, where you can edit dropdown properties
and edit the dropdown option list. Once you are finished with these steps, left click in the grid cell
you want to add the dropdown field to.

You can also create a dynamic dropdown which is populated from the SQL query you provide
when deployed under HID web application. As of 3/10/2005 only clinicalrater mandatory field is
recognized by the Struts code generator in CALM and GAME in HID web app for SQL backed
dropdowns. When you select ’Dynamic’ from the dropdown type selection dialog box , you will
see a dialog box like below, where you can provide the SQL query to retrieve the contents of the
dropdown from the underlying database for HID web app. Once you are done editing dropdown
properties, left click in the grid cell you want to add a dropdown field.
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• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_dropdown { color: blue; font-family: arial;
border-style: solid;
border-color: #0000ff

}

Then you can enter sars dropdown as the class for the text field added to the CALM form
layout design screen. In the final generated JSP the text in the dropdown will will end up in
blue Arial font and there will be a blue border around the text field.

• justification (default Left justified) - used to specify the justification (alignment) of the com-
ponent within its container cell.

2.2.10 Add Button (Alt-B )

This menu item is used to add a submit button to one of the cells in a container. After selecting
the menu item, the corresponding toolbar button or the shortcut Alt-B, left click in the grid cell
you want to add button field.

• action (default Submit, One of Submit, Previous, Next) - the type of button that can be used
with the Generic Assessment Management Engine (GAME) in the BIRN HID web application.
If you have a multiple page assessment form, The first page will have a Next button, all but
the last of the remining pages will have a Previous and Next button. The last page will have
a Previous and Submit button. A single page assessment without a cover page will have a
single Submit button.
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• class (optional) - used for Cascaded Style Sheet (CSS) support. It corresponds to a class selec-
tor in the CSS stylesheet used by the generated JSP pages for the BIRN HID web application.
The class selector must be defined in the $CLINICAL HOME/web/pages/layout/clinical.css
For example, let’s assume you have the following class selector definition in the clinical.css file

.sars_button { color: blue; font-family: arial}

Then you can enter sars button as the class for the button added to the CALM form layout
design screen. In the final generated JSP the text in the button will will end up in blue Arial
font.

• justification (default Left justified) - used to specify the justification (alignment) of the com-
ponent within its container cell.

2.2.11 Select Components (Alt-S)

This menu item enables mouse based selection of a portion of the layout. Just press the left mouse
button outside of the container/ display component(s) you want to select and drag the mouse until
the selection box totally includes the container / display component(s) you want to select. Release
the button. The color of the selected container/ display component(s) will change to blue. If this
does not happen, try again making sure to select all the way to the outer edge of the container.
When you’re components have been successfully selected and are highlighted in blue press the right
mouse button to active the popup menu. You can either

• Save the selected container as a template

• Delete the selected container / display component(s)

• Copy the selected container / display component(s) to be pasted to an another place in the
layout by left clicking the mouse inside the grid cell you want to paste.

• Or logically group or ungroup a group of display components to be associated with a score.
This would be useful for questions involving multiple choices to select from like radio buttons.

2.2.12 Add TemplateComponent (Alt-Z)

This menu item allows you to select a template from the list of previously saved templates and
insert into any location in the currently edited page of the clinical assessment.

2.2.13 Struts Code Generator (Alt-G)

Once you have associated all the assessment scores and the mandatory fields with the form compo-
nents, it is time to generate the JSPs, Struts Form Bean and update the struts-config.xml file for
the Generic Assessment Management Engine (GAME) in the HID web application. For this, either
select Struts Code Generator from the Tools menu or press Alt and G keys simultaneously.
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2.2.14 Show Associations (Alt-H)

Toggles the assessment score association hint information display in the form layout for quickly
detecting which fields are associated with a score. The first 8 characters of the Score name will be
shown in the upper left hand corner of the form field.

2.2.15 Show Association Tips (Alt-O)

Toggles the assessment score association tip display in the form layout for quickly detecting which
fields are associated with a score. Just point your mouse inside a form field. A text describing the
score this component is associtated in a small popup display. If the form field is not associated
with any scores nothing will popup.

2.2.16 Show Question Groups (Alt-Q)

Toggles the question group hint information display in the form layout for quickly detecting which
fields comprise a question. The fields in a question will be
hilited in orange and the question number will be shown in red.

2.2.17 Save Assessment to DB (Alt-D)

Saves the modified assessment, scores, score codes and assessment items ( question text) to the
connected Oracle database if and only if the assessment is not populated with subject data. This
option will first remove the previously existing assessment records and create a new assessment.

2.2.18 Working with Multiple Page Clinical Assessment Layout Documents

While working with multiple page assessment layouts, you can select the page you want work on
by selecting the corresponding page number from the dropdown in the toolbar. You can append a
new page by pressing the plus button in the toolbar.
Once you are down with a document you can select File->Save As to save the layout document in
XML. You can load a saved layout document via File->Open menu item.

2.2.19 Editing container and display element properties

• To edit a display component double click on the component, which will popup a property
dialog, where you can edit the properties of the display component. (See Tools Menu Docu-
mentation (cf. Section ??) ).

• To edit the grid layout of a container, double-click in an empty grid cell or Ctrl-double click
in the container. Please note that, if multiple containers are nested and you want to edit one
of those outer cells, Ctrl- double click outside the border of the container that is included by
the container you want to edit.

• You can delete a display element by right clicking on that display element which shows a
popup menu, from which you select Delete.

• To copy a display component, right click and select Copy from the popup menu.
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• To copy a group of display components ( for example to copy a whole laid out question
), select Tools->Select Components or (Alt - S) and press the left mouse button outside of
the container/ display component(s) you want to select and drag the mouse until the selection
box totally includes the container / display component(s) you want to select and release the
button. Then right click and select Copyfrom the popup menu.

• To logically group or ungroup a group of display components ( like a group of radio buttons
) to be associated with a score, select Tools->Select Components or (Alt - S) and press the left
mouse button outside of the container/ display component(s) you want to select and drag the
mouse until the selection box totally includes the container / display component(s) you want
to select and release the button. Then right click and select Logically Group Selection or
UnGroup Selection from the popup menu.

• Since what constitutes a question is based on the content, the components belonging to a ques-
tion needs to be explicitly specified to CALM especially for generating logic for unanswered
questions, notes handing and multi-answer question logic handling. This is acomplished by;

– Selecting Tools->Select Components (or pressing Alt - S) and pressing the left mouse
button outside of the container/ display component(s) you want to select and drag the
mouse until the selection box totally includes the container / display component(s) you
want to select and releasing the button.

– Right clicking and selecting Group Selection as a Question from the popup menu.

– Editing the question meta data (like question type (regular or multi-answer and at-
tributes like minimum and maximum number of answers) in the shown dialog box.

• To ungroup a selected question, select Tools->Select Components or (Alt - S) and press the
left mouse button outside of the container/ display component(s) you want to select and
drag the mouse until the selection box totally includes the container / display component(s)
you want to select and release the button. Then right click and select Ungroup Selected
Question from the popup menu.

Creating a multi-answer question
A multi-answer question, (like drug dosage history) is laid out like any regular question with fol-
lowing two constraints;
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1. Each multi-answer question needs to be contained within a single container row. Since con-
tainers can be nested arbitarily, the layout possibilities within that single container row is not
limited.

2. Each multi-answer question needs to have an Add button component to add new input inputs
for additional answers (upto the max allowed answer limit)

Once a multi-answer question laid out, the input fields can be logically grouped (for mutually exclu-
sive radio button groups, and check box groups) and associated with their corresponding scores like
a regular question. Then the question needs to be grouped (See Group Selection as a Question
above) and the question metadata information needs to be supplied

1. question type = multi-answer

2. Min Answer = 1 (always needs to be one currently)

3. Max Answer (> 1) (Even if you don’t know the possible maximum answer number, provide
a conservative guess. There will be maximum answer number of hidden form fields, so the
conservative guess needs to be reasonable.)

3 Editing/Creating a New Assessment

CALM allows you to edit an existing assessment or create a new assessment from the scratch.

3.1 Creating a new assessment

Select File->New. You will first presented with the available assessments in the connected database.
CALM connects to your Oracle database during startup and remains connected until you exit. At
this points you will see a dialog box like the one below.

To work o a brand new assessment that is not available in the database, press Cancel button.
You will see the following dialog
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Provide the name of the assessment and press OK. You will see the assessment tree in the assess-
ment layout pane of the main screenx populated with the assessment node and two mandatory
fields, namely Date and Time of the assessment.

3.2 Adding/Editing scores, subscores, score codes and assessment items

For the assessment tree popup-menu, you first select a tree node and right click to show to
popup menu.
Some of popup menus are context sensitive, e.g. their behavior depends on the tree node selected.
”Update” updates the attributes of the selected assessment, score or subscore.

3.2.1 Add Score

Use this popup menu option to add scores. For the first level scores, first select the assessment
name node which is the root node of the assessment tree. (For example, in the screenshot above
you have first level scores Date, Time, InformantID, InformantRelation, and BD. BD has second
level scores (subscores). For second and higher score levels (subscores), first select the parent score
node under which the subscore will be created.

In the New Score dialog specify the score name, score type and security classification.
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3.2.2 Add Subscore (No longer available)

Use this popup menu option to add second and higher level of scores to an assessment. For this
select first select the parent score node, right click and select Add Score Codes from the popup
menu. You will see a New Score dialog box as shown above.

3.2.3 Add Score Codes

Use this popup menu option to add score codes to a score. As a convenience, you will be asked
if you want to select and use some of the text entered in the form layout pane. Score codes are
important for multi-selection questions. They give values to each selection.

If you have pressed Yes button, select Tools->Select Components or (Alt - S) and press the left
mouse button outside of the text display component(s) you want to select and drag the mouse until
the selection box totally includes them and release the button. You will see a dialog box
like below populated. Otherwise you press Add Score Code Button to add new empty score
codes, and enter score code and score code value
fields.
Note: Please make sure that, you have pressed Enter or selected a different score code row, if you
are editing the last row, otherwise your last edit will be lost, because of the way event mechanism
works in a Java Swing table component).
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3.2.4 Add Assessment Item

Use this popup menu option to add an assessment item (question text) for a score to your assess-
ment. For that, select a score node in the assessment tree and right click and select Add Assessment
Item from the popup menu. You need to at specify at least the Leading Text (the main question
body). CALM will ask if you want
to select text from the form layout view to populate the Leading Text portion of the Add Assess-
ment Item dialog. Select the ’Remember Answer’ check box if you
want CALM to not show this dialog box for each question.

If you answer yes, press Alt-S to enter the Selection mode. Then, press the left mouse button
outside of the container/ display component(s) you want to select and drag the mouse until the
selection box totally includes the container / display component(s) you want to select and release
the button. The color of the selected container/ display component(s) will change to blue. The
Add Assessment Item dialog box will be populated with the selected text.
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Another trick to avoid retyping the question is, first double click on the text display component
corresponding to the question,
to show the text properties, select the label field and copy the content into the clipboard by selecting
the text and pressing Ctrl-C. They you invoke Add Assessment Item, and paste the content by
pressing Ctrl-V inside the Leading Text.

3.2.5 Update Assessment Item (added at 3/28/2005)

Use this popup menu option to update an existing assessment item (question text) for a score of
the assessment you are preparing.

3.2.6 Properties

Use this popup menu option to view the attributes of a score (score name, type, score sequence
etc).

3.2.7 Update

Use this popup menu option to edit an existing score, subscore or assessment attributes. You can
select the desired assessment tree node, right click and select Update from the popup menu. This
will update the attributes of the selected assessment, score or subscore.

3.2.8 Update Score Codes

Use this popup menu option to edit existing score codes, remove and/or add new score codes.
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3.2.9 Delete Score

You can only delete leaf scores, i.e. scores without any subscores of themselves. To delete a score
with subscores, start deleting from the deepest subscore and delete all its siblings and so on. Select
the leaf score you want to delete, right click and select Delete Score from the popup menu.

3.2.10 Change Assessment Name

Select this popup menu item to rename the clinical assessment edited.

4 Associating the assessment scores with the form elements

The left pane of the main CALM screen shows the assessment and its score hierarchy and two
mandatory variables, namely Time and Date which should be associated with text edit controls in
the form. (If you have multiple forms for an assessment, then this time and date text boxes must
be in the first form, or in the cover page of the assessment).
Each document can have multiple pages (forms). So you can associate an assessment score with a
component ( like an edit field) or with a group of components ( like a group of radio boxes). When
a score is associated with a form component its tree node becomes green (See below).
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Select a score in the assessment maintenance tree and press Right mouse button to show the
popup menu as shown above. Select Associate from the popup menu.

Now you need to click the right mouse button on the form element (e.g. text edit field) or
one of the form elements within a logical group you want to associate this score. If you want to
associate a score with a logical group, then the score must have a corressponding list of score codes,
otherwise you will get a warning message and not allowed to associate the score with the logical
group of components.

CALM uses the score code values for the selected score from the database (or the offline new
assessment) and by default assigns each form element in the group to the possible score values
in ascending order. You can change the assignment order of the form elements by clicking and
selecting from the drop-down of the table cell under Associated Component column. The security
classification info is read from the database
even though you may be working on a new assessment, which is not persisted to the database yet.
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5 Code Generation from the CALM Form Editor ( for Struts
Framework)

Once you have associated all the assessment scores and the mandatory fields with the form compo-
nents, it is time to generate the JSPs, Struts Form Bean and update the struts-config.xml file for
the Generic Assessment Management Engine (GAME) in the HID web application. For this, select
Struts Code Generator from the Tools menu. You will see the following dialog box;

This the only mandatory information that needs to supplied for the Struts JSP, FormBean Java
code generation and update of the struts configuation file template. Here you specify the location
of the HID web application as checked out from the BIRN CVS repository.
After that, you will see the following dialog box with all fields completed using the Clinical web
application Home directory info just
supplied.
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• Application Context: The J2EE web application context name for the HID web application.
The default is fine for almost all cases.

• Package Name - default is fine for almost all cases

• Form Bean Name - The name of the Struts form bean that will be generated

• Form Bean ID - a logical name for the Struts form bean. It is mainly used in form-bean
declaration in struts-config.xml.template <!– CALM generated start –> <form-bean
name="qmForm"
type="clinical.web.game.forms.QuickMoodForm"/>
<!– CALM generated end –>

• Source Code Root - the directory where your HID web application source code tree is located

• JSP Code Root - the directory where the generated JSP pages will end up.

• Stuts Config File Path - the path for your HID web application struts-config.xml.template file.
CALM form editor updates this file to add the necessary actions and form bean declaration
for the generated JSPs.

• Generated Code Directory - the directory where CALM editor saves the intermediate files
(XForms 1.0 compliant XML files and XSL style sheets used to transform the XForms forms
into the corresponding JSPs.

• Struts Action Prefix - the static part of the Struts action path attribute in the generated
action tag in the struts-config.xml.template.

<!-- CALM generated start -->
<action path="man_quick_mood"

type="clinical.web.game.AssessmentManagementAction"
name="qmForm"
parameter="action"
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scope="session"
input="/pages/assessment/QuickMoodForm\_full.jsp">

<forward name="success"
path="/pages/assessment/QuickMoodForm_full.jsp"/>
<forward name="failure’’

path="/pages/assessment/QuickMoodForm_full.jsp"/>
</action>

<!-- CALM generated end -->

• Relative JSP Path - the default is OK for almost all cases.

• Submit Return Page URL - the default is OK for all cases. The (partial) URL is the return
target the browser will display when the last page of the assessment is submitted.

Since each clinical assessment can map to multiple JSPs, the names of the to be generated JSPs
must be specified. CALM form editor gives them default names.
The initial values are good for almost all cases, you can always edit these values. Next, press OK to
start code generation. As of version 1.7, CALM automaticaly integrates the online assessment with
the HID web application. To start using the newly generated online form in HID web application,
you need to stop your Tomcat, rebuild and redploy by running ant, and restart Tomcat.
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6 New CALM Features (8/17/07)

6.1 Simplified Declarative Assessment Layout XML format Option

Now CALM can recognize a simplified declarative clinical assessment layout XML format. Some
examples of this new format is given in examples directory under the source distribution. The
conventional extension for XML files in this new format is .calm. For example NAART.calm under
examples directory is the new declarative format version of NAART assessment with calculated
fields. The declarative format does not capture user tweaking of the layout in CALM. For this the
assessment needs to be saved in original full-blown CALM XML format.

Below is NAART assessment in its entirety in Simplified Declarative Clinical Assessment Layout
XML format. XML files of this format have the extension .calm.

<calm version="1.0">
<assessment version="1.0">

<name>NAART Test Clinical Assessment</name>

<pages>
<page no="1">

<title>NAART Test Clinical Assessment</title>
<q id="q1" bindingScore="total errors" scoreType="integer">
<text>&lt;b&gt;Total Errors:&lt;/b&gt;</text>
<answerGroup location="east" orientation="horizontal" compType="text"/>

</q>
<q id="q2" bindingScore="VIQ" scoreType="float">
<text>&lt;b&gt;VIQ:&lt;/b&gt;</text>
<answerGroup location="east" orientation="horizontal" compType="text"/>
<expression>128.7 - 0.89*totalErrors </expression>

</q>

<q id="q3" bindingScore="PIQ" scoreType="float">
<text>&lt;b&gt;PIQ:&lt;/b&gt;</text>
<answerGroup location="east" orientation="horizontal" compType="text"/>
<expression>119.4 - 0.42*totalErrors </expression>

</q>

<q id="q4" bindingScore="FSIQ" scoreType="float">
<text>&lt;b&gt;FSIQ:&lt;/b&gt;</text>
<answerGroup location="east" orientation="horizontal" compType="text"/>
<expression>127.8 - 0.78*totalErrors </expression>

</q>
</page>

</pages>
</assessment>

</calm>

This assessment is a single page clinical assessment consisting of four questions, the last three of
these four is calculated based on the value of the first question.

Each .calm assessment file contains a single possibly multiple page assessment enclosed be-
tween matching <calm> tags. The actual assessment declaration is enclosed within a matching
<assessment> tag. First, you need to specify the name of the assessment (enclosed within a
matching <name> tag). The assessment page content is enclosed in a <pages> tag. The questions
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belonging to a page is enclosed within a <page> tag. Each page is numbered, starting from one, by
providing the page number using the no attribute of <page> tag. You can specify a page title using
<title> tag. Questions are numbered starting from one globally for the whole assessment, i.e.
questions, say, for the second page does not start from one. Each question declaration is enclosed
within a q tag.

Each question id is specified by using id attribute of q and have the format q<question-number>.
For questions mapping to a single assessment score, the binding between the question and the as-
sessment score name is provided by the bindingScore attribute of the q. The data type of the
assessment score is specified by the attribute scoreType and can take one of the values integer,
varchar,float,boolean and timestamp. The actual question text is enclosed within a <text> tag.
The form fields to collect the answer from the user are specified within a answerGroup tag. The
type of the form field is specified by the attribute compType of answerGroup and can be one of
radio, text, textarea, checkbox, dropdown or button. The layout of a question’s form field(s)
is declared by specifying their location and orientation relative to the question text using the at-
tributes location and orientation, respectively. The attribute location takes one of the values
east, west,north or south. The attribute orientation takes either horizontal, meaning the
form fields will be aligned next to each other or vertical, meaning the form fields will be stack
on top of each other within a question. This attribute only has an effect if the there are more than
one form field to capture the answer, like multiple choice questions.

A calculated field calculates its value from one or more user specified question answers and
a predefined formula which is declared by an expression tag. A calculated field formula uses
basic arithmetic operations and predefined mathematical functions sin, cos, log, sqrt and exp,
in combination with the bindingScore attribute values for user specified answers from the same
page.

A multiple-choice question with a group of radio buttons can be declared as shown below;

<q id="q1" bindingScore="wide awake" scoreType="integer">
<text>wide awake</text>
<answerGroup location="east" orientation="horizontal" compType="radio">

<answer label="Not at all" code="1"/>
<answer label="a little" code="2"/>
<answer label="moderately" code="3"/>
<answer label="very" code="4"/>
<answer label="extremely" code="5"/>

</answerGroup>
</q>

Here, each possible answer is specified by its own answer tag. The label for the possible answer
is specified by the label attribute and the corresponding score code by the code attribute. A
multiple-choice question with a dropdown can be declared as shown below;

<q id="q2" bindingScore="hallucinating type" scoreType="integer">
<text>Hallucination Type:</text>
<answerGroup location="south" orientation="horizontal" compType="dropdown">

<answer label="">
<component>

<labelValueSet>
<lv label="visual" value="1" />
<lv label="auditory" value="2" />
<lv label="tactile" value="3" />
<lv label="smell" value="4" />
<lv label="taste" value="5" />
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</labelValueSet>
</component>

</answer>
</answerGroup>

</q>

Here, since there is only one answer form input field, one answer tag with empty label is defined.
The form component is specified by a component tag. The possible choices in the dropdown is
encapsulated in a labelValueSet tag as individual lv tags. The label shown to the user is specified
with a label attribute, while the integer value sent back to the HID database via a value attribute.
To make this question a multiple-answer one, you need just set question type attribute with value
multiple-answer and question maxAnswer attribute with maximum number of answers allowed as
shown below;

<q id="q2" bindingScore="hallucinating type" scoreType="integer"
type="multiple-answer" maxAnswer="5">
<text>Hallucination Type:</text>
<answerGroup location="south" orientation="horizontal" compType="dropdown">

<answer label="">
<component>

<labelValueSet>
<lv label="visual" value="1" />
<lv label="auditory" value="2" />
<lv label="tactile" value="3" />
<lv label="smell" value="4" />
<lv label="taste" value="5" />

</labelValueSet>
</component>

</answer>
</answerGroup>

</q>

A timestamp field with validation can be specified as shown below;

<q id="q1" bindingScore="FAVDAY" scoreType="timestamp" scoreTypeFormat="MM/dd/yyyy" >
<text>1) Favorite Day (MM/DD/YYYY): </text>
<answerGroup location="east" orientation="horizontal" compType="text"/>

</q>

A multiple-score question can be specified as shown below;

<msq id="q8">
<text>8) Enter a family member record below. </text>
<subq bindingScore="FAMREL" scoreType="integer">
<text>8a) Relation to Subject:</text>
<answerGroup location="east" orientation="horizontal" compType="radio">

<answer label="Sister" code="1"/>
<answer label="Brother" code="2"/>
<answer label="Father" code="3"/>
<answer label="Mother" code="4"/>

</answerGroup>
</subq>
<subq bindingScore="FAMFAVDAY" scoreType="timestamp"
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scoreTypeFormat="MM/dd/yyyy" >
<text>8b) Favorite Day (MM/DD/YYYY): </text>
<answerGroup location="east" orientation="horizontal" compType="text"/>

</subq>
</msq>

Here each subquestion is specified by a subq tag. A subquestion cannot be recursive, besides that
any of the available question features can be used.

Question skipping buttons for setting predefined sets of questions as to be skipped can be defined
also easily;

<skip afterQuestionId="q1" javascriptOnly="true" label="Skip">
<questionIds>2,3,7</questionIds>

</skip>

The afterQuestionId attribute specifies after which question the skip button will be placed. If
all the questions to be skipped are all on the same page set javascriptOnly attribute to true, if
they span multiple pages, set this attribute to false. The comma separated list of question ids to
be skipped are provided in questionIds tag.

Example assessments can be found in examples directory of your CALM distribution.

6.2 Minimal login parameters

The database connection information is only configured by ant from now on. The user only needs
to select the configured database type and provide the database connection password as shown in
Fig. 1

Figure 1: CALM Login

6.3 Automatic Clinical Assessment Online Form(s) Creation by Import
from Excel Worksheets

CALM can import assessment data and create online assessment data entry forms automatically
via its Import wizard.

6.3.1 Excel WorkSheet Format

Each Excel worksheet is assumed containing question information and individual assesment data en-
tries in separate Excel worksheets in an Excel workbook. Currently only Microsoft Excel 97/2000/XP
format is supported. From newer version of Excel, you can easily save in this format by using Save
As file menu option. In the Excel workbook dependending on whether you have assessment score
codes or not, you need either two or three worksheets.

The first worksheet contains assessment scores, their data types and the corresponding question
text. It needs to have four columns with column headers titled SCORESEQ, SCORENAME, SCORETYPE
, QUESTION. An example for a demographics scale, is shown below;
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SCORESEQ SCORENAME SCORETYPE QUESTION
1 Race varchar Race
2 Ethnicity varchar Ethnicity
3 Education integer Education (years)
4 Mother’s Education integer Mother’s Education (years)
5 Father’s Education integer Father’s Education (years)
6 Occupation varchar Occupation

If there are questions where the user selects her answer from a list of answers, than you need
a second worksheet to define your score codes. This worksheet needs to have six columns with
column headers titled SCORENAME, QUESTION, SCORECODE, SCORECODETYPE, SCORECODELABEL and
SCORECODEVALUE. An example for a demographics scale, is shown below;

SCORENAME QUESTION SCORECODE SCORECODETYPE SCORELABEL SCOREVALUE
Ethnicity Ethnicity 1 varchar Hispanic or Latino Hispanic or Latino
Ethnicity Ethnicity 2 varchar Not Hispanic or Latino Not Hispanic or Latino
Gender Gender F varchar Female Female
Gender Gender M varchar Male Male

Currently, SCORECODETYPE column is not used, however it needs to exist between SCORECODE
and SCORECODELABEL columns for CALM clinical data upload to work properly. You can leave cells
for this column blank.

The assessment data is provided by the last worksheet. This worksheet needs to have five
standard columns plus one for each assessment score. Each assessment data entry needs to have
first five columns with column headers titled Site, subjectID, subjectType, experimentName and
timeStamp. An example for a demographics scale with first three scores , is shown below;

Site subjectID subjectType experimentName timeStamp Race Ethnicity Education
Duke 000373694353 schizophrenic testExperiment 0011 04/25/2006 5 2 12

schizoaffective patients 12
Duke 000324094767 healthy comparison testExperiment 0011 01/31/2006 5 2 13

subjects
UCI 000901283448 schizophrenic testExperiment 0011 10/28/2005 4 2 NC:No

schizoaffective patients data entered

Here subjectType is the research group name assigned to this subject for this experiment. It is
assumed that an experiment with name matching the corresponding experimentName column value
exists and research groups for this experiment is created via HID web application or other means.
The Site column holds the short name given to a BIRN site at which the subject is assessed. Each
site also gets a four-digit site ID. HID web app is configured to recognized this site name – site ID
pairs. The timeStamp column contains the date and if available the time of the clinical visit. This
timestamp needs to have one of the following formats

MM/dd/yyy
MM/dd/yyyy HH
MM/dd/yyyy HH:mm
MM/dd/yyyy HH:mm:ss

where months range between 1 and 12, days between 1 and 31, hours between 00 and 23. Missing
score values are indicated by prefixing any of the following reasons with NC:

• No data entered

• Subject declined to answer the question
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• Interviewer forgot to ask the question

• Interviewer deferred the question

• Question is excluded from the protocol

• Question is not applicable to the subject

• Answer is not intelligible

• Answer is unknown to the informant

• Missing Value

6.3.2 Importing an Excel Workbook to automatically create an online assessment

On File menu, select Import, to start CALM import wizard. You will see a screen like in Figure 2.
On this screen, first select the Excel worksheet containing clinical assessment and (possibly) cor-
responding data from your computer. Then provide a name for your assessment and select the
question layout from one of the eight possible question layouts. Each layout differ by the relative
position of the question text to the form inputs for capturing the answer and how are multiple form
inputs for a question will be laid out. By default, each question which has some score codes assigned
by the score codes worksheet will have a set of radio buttons to let the user to select an answer. In
the preferences section of this page, you can override this default behavior if you prefer a dropdown
instead of a group of radio buttons for this kind of questions. After that, press Next to move to
the wizard screen (see Fig. 3). On this screen, you are given to methods to assign questions to
each online assessment form page.Either you can assign the same number of questions, in the order
they appear in the excel worksheet or you can individually assign questions to each form page as in
Fig 4. You can select a range of questions by pressing and holding Shift key when selecting with
the mouse or you can select multiple items individually by pressing and holding Ctrl key, while
selecting with the mouse. Once you press Finish button, your assessment forms will be shown in
CALM.

6.4 Assessment Data import to the database from Excel Worksheets

Given that you have created an experiment and its research groups using HID web application
or other means, you can upload clinical assessment data in bulk via CALM. On Tools menu,
select Assessment Data Upload to popup the screen shown in Fig 6. select the Excel worksheet
containing clinical assessment and corresponding data from your computer by using File Browser
button next to the Import button. Now, press the Import button to validate and load clinical data
into CALM. CALM will make an attempt to find and select the matching assessment information
stored in the database, if it cannot find a match it will give a warning and allow you to select the
assessment name the clinical data belongs to. It is assumed that all the clinical assessments in the
worksheet belongs to a single experiment/project. Once you select the experimental protocol from
the Protocol dropdown, you can start assessment data upload by pressing Upload button. While
your HID database is populated with clinical data, CALM will show the progress of the upload.
If for any reason any of the clinical data records fails to upload, CALM will generate a CSV file
including only the failed records and the reason for failure, to facilitate identifying and fixing errors
in the data and reupload.
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Figure 2: Import Wizard

6.5 Saving Assessment type information to the database from a list of
CALM assessment documents

From Tools menu select Bulk Save Assessment item, to display the batch assessment metadata
generation dialog box (See Fig. 7). In this dialog box, first select the directory under which the
CALM assessment forms in the original CALM XML document format are kept. Other that, select
the assessments whose metadata will be inserted into your HID database by pressing and holding
Shift key when selecting a range or by pressing and holding Ctrl key when selecting multiple items
individually.
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Figure 3: Import Wizard - Assigning questions to form pages (Method 1)

7 Tips, Best Practices for Assessment From Layout using
CALM

7.1 A typical top level container

Each form page laid out in CALM, should have a topmost CALM container with at least two
rows. The mandatory footer section is in the last row of this topmost container and usually has
10% or less row percentage. Within the footer row, put a single row container with 3 columns of
column percentages 90%, 5% and 5%, respectively. The Previous, Next or Submit buttons go into
columns 2 and 3. If you are laying out the first page (mostly the cover page) you need to put a Next
or Submit (in case this form page is the only page for the assessment) button in the 3rd column.
For other form pages excluding the final page, you need to put a Previous button in 2nd column
and a Next button in 3rd column of the footer section container. The last page of a multipage
assessment (including the cover page) needs to have a Previous button in 2nd column and a Submit
button in 3rd column (See Figure 8).

7.2 Laying out a body section consisting of rows with exact column spac-
ing

If you have sections of a paper form that have a symmetric grid layout (each row of form elements
have exact number of columns with exact spacing), use a single CALM container to lay them out.
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Figure 4: Import Wizard - Assigning questions to form pages (Method 2)

7.3 Laying out a body section with rows of different column spacing

Since the HTML table column widths and heights are just suggestion to a browser and every
browser implements its internal HTML table layout differently. In case you have a container
layout with different column spacings in different rows, you should not lay it out using a single
container. You should use nested containers. Rows of form elements with exact column spacing
should be laid out in a single container. Always use the Preview tab to check how the form page
will look like in a browser. The preview tab panel is not WYSIWYG, however the final layout in
the HID web app will look very similar to what is shown in the Preview tab panel. Let’s assume,
you want to layout a section of the form page body like the one shown below in Fig. 9.

Step 1 - The outer container for this layout will have 2 rows and a single column (Fig 10).
Step 2 - Then add the second level of containers (in blue) with equally spaced columns (Fig 11).

Step 3 - The third level containers (in red) have also equally spaced columns. At this step your
layout is complete (Fig 12).

7.4 Best Practices/Tips

• Save an reoccuring section /form layout as a template for reuse. To create a template;

– Select the portion of the layout you want to include in the template by pressing Alt-S and
pressing and holding the left mouse button in the upper left corner of the portion of the
form layout to be included in the template and dragging the mouse pointer until the blue
rectangle includes every form display element to be templatized and releasing the mouse
button. Then press the right mouse button to show the popup menu and select Create
a template menu item.CALM will ask you for the template file name. The template file
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Figure 5: Imported assessment

Figure 6: Assessment Data Upload Dialog Box

must have the extension ’.xml’ and is saved into the directory $CALM HOME/templates
by default.

– To insert a template into a form layout, from the tools menu, select Add Template
component. From the available templates select the template name you want and press
Add (Fig 13).

• Make sure each question laid out is totally enclosed within a single container. Within this
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Figure 7: Batch Save Assessments Dialog Box

Figure 8: A typical top level container

Figure 9:

container you can lay out the question the way you want. The algorithm used to place
the unanswered question notes icon to the left upper corner of the question relies on this
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Figure 10:

Figure 11:

Figure 12:

assumption.

• Logically group radio buttons once you layout every page of the assessment .

• Check boxes cannot be logically grouped currently in CALM and each checkbox should be
mapped to a single score currently.

• Associatiate scores with individual form fields (text field, dropdown , textarea field, individual
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Figure 13:

checkboxes) or logical groups (radio buttons).

• Group every component that constitutes a question as a question for each question in the
assessment. Since what constitutes a question is based on the content, the components be-
longing to a question needs to be explicitly specified to CALM especially for generating logic
for unanswered questions, notes handing and multi-answer question logic handling. This is
acomplished by;

– selecting Tools->Select Components (or pressing Alt - S) and pressing the left mouse
button outside of the container/ display component(s) you want to select and drag the
mouse until the selection box totally includes the container / display component(s) you
want to select and releasing the button.

– Right clicking and selecting Group Selection as a Question from the popup menu.

– Editing the question meta data (like question type (regular or multi-answer and at-
tributes like minimum and maximum number of answers) in the shown dialog box (See
Fig. 14).

Figure 14:

• To ungroup a selected question, select Tools->Select Components or (Alt - S) and press the
left mouse button outside of the container/ display component(s) you want to select and
drag the mouse until the selection box totally includes the container / display component(s)
you want to select and release the button. Then right click and select Ungroup Selected
Question from the popup menu.
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• Provide numerical score codes and textual (if available) score code values for scores that have
a known set of answers (See below for an example of a score of this kind (Fig. 15).

Figure 15:

• Add an assessment item (cf. Section 3.2.4) for each question.

• Use (new added feature) association tips for checking if form fields are associated with correct
scores. Just point your mouse inside a form field. A text describing the score this component
is associtated in a small popup display. If the form field is not associated with any scores
nothing will popup.

8 Hot Keys and Faster Editing Tips

Hot Key
Description
Alt-C
To add a container to the current layout page
Alt-E
To add a multi-line text component to the current layout page
Alt-R
To add a radio button to the current layout page
Alt-X
To add a checkbox to the current layout page
Alt-T
To add a text input field to the current layout page
Alt-A
To add text area field ( a multiline text field) to the current layout page
Alt-B
To add a button to the current layout page
Alt-S
To select a group of components in the current layout page (See also this (cf. Section 2.2.11))
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Alt-Z
To add template (a saved group of components) to the current layout page
Alt-G
To generate Struts code for HID web app from the current layout
Alt-H
To toggle score association hints
Alt-D
To save the new (or updated) assessment to the database with all its scores, score codes and ques-
tions
Ctrl-Shift-Left Mouse Click
To change a (multiline) text components content quickly.
Ctrl-Left Mouse Double Click
If inside a container, shows the Grid Layout Manager for the container to edit the layout of the
container
Multiple Paste
First, select a group of components (cf. Section 2.2.11), click right mouse button to show the popup
menu and select Copy. Press and hold the Control key, while
clicking left mouse key in empty container cells where you want to paste the copied components.

9 FAQ

9.1 Q1. not a valid database user: <db-user-name>

In the nc databaseuser database table there needs to be a record for the database user ’<db-
user-name>’. Since every table has mandatory OWNER and MODUSER columns in order to be
able to insert any records you need to have a record for the database connection user name in the
nc databaseuser table.

Another cause of this problem (if you have the necessary record in the database) is the case
insensitivity of Oracle database users , while the nc databaseuser name column is case sensitive.
The user names must be entered as upper case to the nc databaseuser table for equivalence
checking.

9.2 Q2. error: ORA-02291: integrity constraint
(<your-Oracle-schema>.FK ASSESSMENT SELF) violated - parent
key not found.

The error you are seeing is a self referencing foreign key does not allow you to enter data. I am not
sure about the utility of this specific foreign key, I have removed it in my database(s) using SQL
like this

ALTER TABLE nc assessment drop CONSTRAINT FK ASSESSMENT SELF;

9.3 Q3. error: ORA-02291: integrity constraint
(<your-Oracle-schema>.FK NC ONTOLOGYSOURCENC ONTOLOG)
violated - parent key not found.

While currently there is no ontology, the ontology related tables needs to have some place holder
records to satisfy the foreign keys. You can just insert a record to the nc ontologysource table
with column values
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• ontologysource - ’UMLS’

• uniqueid - a unique (within this table) number for this record

• tableid - from your nc tableid table (tableid column for nc ontologysource table)

• owner ( uniqueid from your nc databaseuser for the database user you will connect to the db
via CALM

• modtime - SYSDATE

• moduser- ( uniqueid from your nc databaseuser for the database user you will connect to the
db via CALM

• sourceuri - empty string

• description - something like ’just a placeholder’
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